Counterman
Search
Article

I have a 1995 Mitsubishi Eclipse RS.


6/2/2009

I have a 1995 Mitsubishi Eclipse RS. I bought the car with a bad motor. I got another motor and swapped them out. Now the thing that gets me is that I have to spray starting fluid into the throttle body to get it to start, but only for the first time. Once it starts and runs, it drives great. I can even shut it off and re-crank it a few minutes later without any problem. It only seems to need starting fluid to crank it the first time or after it has been off for about an hour. What can cause this? I was wondering if the MAP could have something to do with it — maybe not reading the correct barometric pressure or something? Maybe a faulty ECU? Thank you!
 
It sounds like the fuel injection system is not holding residual pressure. Check the fuel pressure with an EFI gauge kit and see how quickly fuel pressure bleeds off after shutdown. The FUEL PRESSURE REGULATOR may be faulty, or not connected properly, allowing fuel pressure to bleed off through the return line.


Jim O'Neill - Chino Autotech Inc., Auto Club SoCal AAR
SAE Int'l SoCal Section Board of Governors,
Vice Chair, Service Technology Programs
NASTF Service Information/Communications Committees
Auto Value/Bumper-To-Bumper CSC Nat'l Council
ASE CMAT-L1, CA. Smog Check Technician
AMI AAM Accredited Automotive Manager













Advertise     Contact Us     Subscribe    
Babcox Media • www.babcox.com
3550 Embassy Parkway, Akron, OH 44333
330-670-1234 • (FAX) 330-670-0874
Babcox Website Counterman: Home